Welcome, Guest
Username Password: Remember me

TOPIC: Backup media missing upon restore

Backup media missing upon restore 1 year, 6 months ago #167208

  • autumnleaves
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 72
  • 1 year, 6 months ago
Prior to reinstalling a Linux system I made a backup of a project. Since the media files are on a separate drive I assumed there was no need to include them in the project. Upon restoring from the backup after the reinstallation, I discovered that the media are no longer included in the project. I assume this is because, although the physical location did not change, the username did change, presumably resulting in a new path to the media directories. Is there a fix that will reinsert the media in the project?
Thank you for your attention.

Re: Backup media missing upon restore 1 year, 6 months ago #167212

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20142
  • 1 year, 6 months ago
Hello,

Should be. The way depends on how media have been imported and what happened to the internal Lightworks Media Location(s) after re-installing. Lighworks Media Locations are user-definable internal media spaces managed by the program. They are used to store media imported via Copy Local and Transcode and for link files needed to access (and relink) media imported with Create Link.

Did you make a backup of the folder structure ~/Lightworks before re-installing?
It's better to travel well than to arrive...
Last Edit: 1 year, 6 months ago by hugly.

Re: Backup media missing upon restore 1 year, 6 months ago #167213

  • autumnleaves
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 72
  • 1 year, 6 months ago
Thanks for getting back to me. The media files have not been changed physically. Only the username in ubuntu, which has resulted in a new pathname to the files. I made a backup in a separate location and restored to the newly installed lightworks (on a new Ubuntu version). I am assuming this is why Lightworks does not find the media files for the restored project.

Re: Backup media missing upon restore 1 year, 6 months ago #167214

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20142
  • 1 year, 6 months ago
The question is, which import method did you use when importing the media for the project and,
is the old ~/Lightworks/Media folder (with it's content before the installation) still present somewhere?
It's better to travel well than to arrive...
Last Edit: 1 year, 6 months ago by hugly.

Re: Backup media missing upon restore 1 year, 6 months ago #167218

  • schrauber
  • OFFLINE
  • Platinum Boarder
  • Posts: 3234
  • 1 year, 6 months ago
To avoid misunderstandings, the information in this video should be known:


Did you create the backup from the project settings of Lightworks, and what backup options were set?

What is in the clip file card, the "Metadata" / "Media Location" notes. (a red file paths, or only "offline"?)
Mainly automatically translated
--------------------------------------------
Windows 10, 64 Bit
Intel i5-4440 (3,1 GHz) ; Intel HD Graphics 4600
Last Edit: 1 year, 6 months ago by schrauber.

Re: Backup media missing upon restore 1 year, 6 months ago #167221

  • autumnleaves
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 72
  • 1 year, 6 months ago
Thanks for your follow up on the query. The media files were imported with the default Create Link setting. The new installation of Ubuntu was made to the entire disk which held the former installation. Therefore no folders remain from the original Lightworks installation. The media reside on a separate drive, and the backup was saved to this separate drive so that it could be restored to the new installation.

Under the Log tab of Lightworks, there is no Metadata information after restoration of the backup.

If links to the media files were saved as part of the backup (which I presume to be the case) they need to be modified to the new username of the media file. E.g., where the files were formerly at /priam/media/montage, they can now be found at /agamemnon/media/montage (actually in a subdirectory, but that structure remains unchanged).

Thanks for your help.

Re: Backup media missing upon restore 1 year, 6 months ago #167222

  • autumnleaves
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 72
  • 1 year, 6 months ago
After viewing the video: Can the media link files be edited with a text editor in order to change the path to the actual audio and video files that were imported into the project with "Create Link"?

Re: Backup media missing upon restore 1 year, 6 months ago #167223

  • autumnleaves
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 72
  • 1 year, 6 months ago
The relink media command does not find all the media, since they are dispersed over a handful of directories (2 different cameras, different sessions, separate audio files).

Re: Backup media missing upon restore 1 year, 6 months ago #167228

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20142
  • 1 year, 6 months ago
Relink missing media from timeline menu doesn't work. That's a bug. It works only on selected clips in bins.

To relink media at different locations you have to execute "Media.Relink missing" for each location separately.

If "Media.Relink missing" is greyed out on certain clips, you're in trouble.
It's better to travel well than to arrive...
Last Edit: 1 year, 6 months ago by hugly.

Re: Backup media missing upon restore 1 year, 6 months ago #167258

  • autumnleaves
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 72
  • 1 year, 6 months ago
What if I were to assemble all the media in a single directory and then do the relink to that directory? Thanks

Re: Backup media missing upon restore 1 year, 6 months ago #167259

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20142
  • 1 year, 6 months ago
Should work as well, but there are issues when re-linking missing media under certain conditions (causes unknown). Alternatively it might be necessary to re-import the clips and use Find clips to fill sequence - but there are also issues under certain conditions.

All in all, best would be if you would try now to relink one single clip first (selected in Filter.Clips or opened in a viewer) and tell about the results.
It's better to travel well than to arrive...
Last Edit: 1 year, 6 months ago by hugly.

Re: Backup media missing upon restore 1 year, 6 months ago #167264

  • schrauber
  • OFFLINE
  • Platinum Boarder
  • Posts: 3234
  • 1 year, 6 months ago
autumnleaves wrote:
...Under the Log tab of Lightworks, there is no Metadata information ...

Is this independent of which clip in Project Content you double-click?
This image is hidden for guests. Please log in or register to see it.


Or do you see that ?:
This image is hidden for guests. Please log in or register to see it.
For example, at least the clip name, etc. should be displayed in the metadata. Otherwise, there are some misunderstandings in this discussion?
(Screenshots could avoid misunderstandings.)


autumnleaves wrote:
... after restoration of the backup...

Did you create the backup here ?:
This image is hidden for guests. Please log in or register to see it.


Or with another backup program?
Mainly automatically translated
--------------------------------------------
Windows 10, 64 Bit
Intel i5-4440 (3,1 GHz) ; Intel HD Graphics 4600
Last Edit: 1 year, 6 months ago by schrauber.

Re: Backup media missing upon restore 1 year, 6 months ago #167265

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20142
  • 1 year, 6 months ago
autumnleaves wrote:
I made a backup of a project. Since the media files are on a separate drive I assumed there was no need to include them in the project.

From your initial post I've been assuming that you did a project backup from within Lightworks and didn't include any media..

But, it's really worth it confirming that!

Did you use Project.Details.Backup?
It's better to travel well than to arrive...
Last Edit: 1 year, 6 months ago by hugly.

Re: Backup media missing upon restore 1 year, 6 months ago #167281

  • autumnleaves
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 72
  • 1 year, 6 months ago
Thanks for your further questions.
1. The project backup was made from within Lightworks, but media was not backed up because it is stored on a separate drive. Here is a shot of the backup files created by Lightworks.
2. The raw media files (including 2 cameras, 2 sessions plus raw audio and processed audio) are all located in a directory /Local Bands/Audrey/2017... which is contained in the drive /agamemnon/media/Montage. However, I foolishly changed the username when I installed the new version of Ubuntu; the old path to the drive containing the project media was /priam/media/Montage. This change of location is presumably why the Lightworks restore function was unable to locate the media files.
3. After attempting a LW restore and using the Relink Missing... command to find the media files in Montage/Local Bands/Audree/2017.... I am only able to re-link one file. There should be a dozen or so media files in the project, the video files being in the various subdirectories. Relink Missing did not find the audio files, which are not ina subdirectory. Note too that the Sequence#1, also not located in a subdirectory, did not get restored.
I hope this information helps.
Would I have better luck if I placed all the media in a single directory and did Relink Missing to that directory?
The LW backup files which contain the old path to the media do not appear to be editable with a text editor.
Attachments:
  • Attachment This image is hidden for guests. Please log in or register to see it.
  • Attachment This image is hidden for guests. Please log in or register to see it.
  • Attachment This image is hidden for guests. Please log in or register to see it.

Re: Backup media missing upon restore 1 year, 6 months ago #167283

  • khaver
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 3391
  • 1 year, 6 months ago
When you create a backup that is going to be restored to a new user or new computer, you need to at the least include Local Media. This will backup and restore all the link files to your original video/audio files that Lightworks creates when you import them into your project.
Work Comp: Retired!
Home Comp: Newer! Bigger! Faster!
Send me a tip: paypal.me/4khaver
Time to create page: 0.39 seconds
Scroll To Top