Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: [Solved] External audio not in time/sync with video/internal audio

[Solved] External audio not in time/sync with video/internal audio 6 years, 5 months ago #66172

  • unkoh
  • OFFLINE
  • Fresh Boarder
  • Posts: 6
  • 6 years, 5 months ago
(I'm hopefully not duplicating a thread)

I shot an interview using a m43 camera and audio with a shotgun into my laptop using Audacity.

The video is 29.97fps imported into a 30fps project.
The internal audio is in synch with the video.


The external audio is slightly out of time with the audio from the video. So when I synced it at one point, after a few minutes it is a couple of seconds out of sync.

I worked it out to be a difference between 29.97fps/30fps.

I worked out two solutions:

1. Speed up my external audio within Lightworks (100.1001%). But I need to export at 30fps. (Exporting at 29.97fps still has timing issues.)
2. Speed up my external audio in Audacity then import it. I can then export from Lightworks at 29.97fps.

I prefer to speed up the external audio in Audacity so that I do not have to change the exported frame rate.

So I have a workaround, but it seems odd to me that I might need to do this.


What I'm trying to work out is if this is a "Lightworks problem" or is just one of those things you have to deal with when using external audio?

As in, is Lightworks playing the 29.97fps video at 30fps and so making it a tiny bit faster than it should be?


P.S. I'm not looking for better video camera or mic solutions. I know ideally I'd have a camera which has audio inputs but I don't. At least not for now.
Last Edit: 6 years, 3 months ago by shaunthesheep.
The topic has been locked.

Re: External audio not in time/sync with video/internal audio 6 years, 5 months ago #66179

  • shaunthesheep
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 2711
  • 6 years, 5 months ago
Welcome to the forum.

Have you set the Output Format in the Lightworks Project Card (top left of Lightworks screen) > Video tab?

There is a drop down menu where you can "refine" (for want of a better word) the frame rate from 30 fps to 29.97 fps. See screen shot:

This image is hidden for guests. Please log in or register to see it.
Desktop
Dell Inspiron 560MT. Intel Core 2 Quad Q8300 Processor, 6 GB Dual Channel DDR3, Windows 7 64 bit SP1/Ubuntu Studio 14.04.2 duel boot. On-board graphics chip. Samsung SyncMaster S23B35OH LED monitor. EchoAudio Mia 24/96 soundcard.

Laptop
Dell Precision M6700, i7 3740QM CPU @2.70Ghz, NVidia Quadro K3000M, 8GB ram. Windows 7 64 bit SP1.

I am not employed by EditShare. I am a Lightworks user.
Last Edit: 6 years, 5 months ago by shaunthesheep.
The topic has been locked.

Re: External audio not in time/sync with video/internal audio 6 years, 5 months ago #66235

  • unkoh
  • OFFLINE
  • Fresh Boarder
  • Posts: 6
  • 6 years, 5 months ago
I had tried changing the output format but it didn't make a difference. It was by default set to 1080 29.97fps anyhow.

(Actually, what is changing the output format meant to do (since when exporting you can specify those details anyway)?)
Last Edit: 6 years, 5 months ago by unkoh.
The topic has been locked.

Re: External audio not in time/sync with video/internal audio 6 years, 3 months ago #70005

  • BryanJ
  • Edu User
  • OFFLINE
  • Junior Boarder
  • Posts: 28
  • 6 years, 3 months ago
What I'm trying to work out is if this is a "Lightworks problem" or is just one of those things you have to deal with when using external audio?

As in, is Lightworks playing the 29.97fps video at 30fps and so making it a tiny bit faster than it should be?


Hi unkoh,

Your project is 30fps. Your video is 29.97fps. When you import your external audio file, you need to tell Lightworks to play your external audio at 29.97fps, loosely speaking.

Click on Import then highlight your external audio file. Right click, then:

Audio-only media > Pre-ingest sync > Picture @ 29.97fps

Click the Import button (use Create Link when importing).


Now your external audio will play in sync with your 29.97fps video.

We have an old project that we were working on just now that we'd forgotten to do this on so the sync was out. It is now fixed by this process.

Someone gave us this advice many moons ago. I hope you benefit from it too!
Last Edit: 6 years, 3 months ago by BryanJ.
The topic has been locked.

Re: External audio not in time/sync with video/internal audio 6 years, 3 months ago #70021

  • unkoh
  • OFFLINE
  • Fresh Boarder
  • Posts: 6
  • 6 years, 3 months ago
You ripper!

Yeah, that worked. Life just got a little better.
The topic has been locked.
  • Page:
  • 1
Time to create page: 0.38 seconds
Scroll To Top