Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: Sometimes I can't add a transition, why?

Sometimes I can't add a transition, why? 1 month, 2 weeks ago #210789

  • thesunray
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 25
  • 1 month, 2 weeks ago
Curious, I have a number of clips and mostly they're 10 secs or longer, rarely super short. Yet sometimes, on a third or fourth of them, I'm unable to add a "Dissolve" transition of 12 or even 6 frames, due to "insufficient space." I can understand that if the clips are just a second or so, but they're not...is something else about them causing this error? Am I doing something wrong?

To create a transition I usually hover between the two clips and right click, then choose "Transition > Add" from the menu. Should I be in the video editor for this?

Just confused as to why this message is happening when I'm using decently long enough clips.

Thank you!

Re: Sometimes I can't add a transition, why? 1 month, 2 weeks ago #210792

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22610
  • 1 month, 2 weeks ago
Hello,

It's not the duration of a clip which counts, it's the available overlap on both sides of the cut.

By nature a dissolve mixes two video streams. It needs two overlapping clips. Inline transitions applied to a single track do that by using material from the clips left and right of the cut. The overlapping material isn't visible in the timeline, it's cut off. If there's no hidden material on either side, you'll see that message. If there's at least one frame on each side for the overlap, Lightworks will shorten the transition to match the available overlap with a different message.

This image is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...
Last Edit: 1 month, 2 weeks ago by hugly.

Re: Sometimes I can't add a transition, why? 1 month, 2 weeks ago #210793

  • schrauber
  • OFFLINE
  • Platinum Boarder
  • Posts: 3878
  • 1 month, 2 weeks ago
hugly wrote:
.. Inline transitions applied to a single track do that by using material from the clips left and right of the cut. The overlapping material isn't visible in the timeline,

Or in other words: Lightworks automatically creates an overlap in the background by loading more frames from the item of the project content into the transition. For this to work, there must be more frames in the project content than have been inserted into the timeline.


hugly wrote:
.. If there's no hidden material on either side, you'll see that message..
The solution is to remove enough frames from one or both segments at the cut without creating a gap. This creates a reserve in the background that is used for the transition.
Mainly automatically translated
--------------------------------------------
Software: Lightworks 14.6 Beta & 14.5; || Windows 10, 64 Bit
Hardware: Intel i5-4440 (3,1 GHz); || shared RAM: 8 GB; || Intel HD Graphics 4600 (can use max. 2 GB of shared RAM)
Last Edit: 1 month, 2 weeks ago by schrauber.

Re: Sometimes I can't add a transition, why? 1 month, 2 weeks ago #210795

  • thesunray
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 25
  • 1 month, 2 weeks ago
This image is hidden for guests. Please log in or register to see it.



I'm hoping this png file uploads...you can see that there are some very short clips that all have a gray "dissolve" and then two quite long clips that don't. I don't think it's an issue like what you say unless I'm missing something. Why would a dissolve not work in the middle between two long clips, each of which have a successful dissolve at either end?

Re: Sometimes I can't add a transition, why? 1 month, 2 weeks ago #210796

  • thesunray
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 25
  • 1 month, 2 weeks ago
Or am I not understanding the "overlap"? In reading above, does it mean that it can only create a dissolve (or other transition) when there's a head and tail that's not part of the shown clip?

So (put differently) if I have a clip that's red that's placed non-overlapping with another clip that's blue, so there's no purple part that's the two clips overlapping, it won't work?

That suddenly makes sense. Thank you for the help. I'll try to adjust those so there's some overlap!

Re: Sometimes I can't add a transition, why? 1 month, 2 weeks ago #210802

  • briandrys
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 9031
  • 1 month, 2 weeks ago
This thread goes into the issues that can arise with transitions, together with solutions.
www.lwks.com/index.php?option=com_kunena&func=view&catid=7&id=143120&Itemid=81
  • Page:
  • 1
Time to create page: 0.74 seconds
Scroll To Top