Welcome, Guest
Username Password: Remember me

TOPIC: [SOLVED] 14.0 crashes upon opening.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141886

  • JimDaddyO
  • OFFLINE
  • Junior Boarder
  • Posts: 37
  • 1 year, 11 months ago
I was looking at that file and I see a few incorrect things off hand. First...it is a Win 10 machine, also, I am logged in as the administrator. I am googling the error... CreateClassEnumerator.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141890

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 17716
  • 1 year, 11 months ago
The CreateClassEnumerator doesn't say much, the error.log neither.

I assume you copied the error.log after the crash has occured.

Trial and error might bring us forward. Let's see if the problem is related to project data or some kind of driver.

Please rename "Projects" folder in
C:\Users\Public\Documents\Lightworks\
to "Projects.temp" and start Lightworks.

Does it crash?
It's better to travel well than to arrive...
Last Edit: 1 year, 11 months ago by hugly.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141895

  • JimDaddyO
  • OFFLINE
  • Junior Boarder
  • Posts: 37
  • 1 year, 11 months ago
hugly wrote:
The CreateClassEnumerator doesn't say much, the error.log neither.

I assume you copied the error.log after the crash has occured.

Trial and error might bring us forward. Let's see if the problem is related to project data or some kind of driver.

Please rename "Projects" folder in
C:\Users\Public\Documents\Lightworks\
to "Projects.temp" and start Lightworks.

Does it crash?


You sir, are a genius. That seems to have done it. I opened it up and imported a couple of files and threw them on and it seems to work. Thank you so very much.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141904

  • JimDaddyO
  • OFFLINE
  • Junior Boarder
  • Posts: 37
  • 1 year, 11 months ago
Oh, and I had to copy and paste the lw3.ttf file to the lightworks directory manually too. Hope this all helps someone else.

Thanks again for the help.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141905

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 17716
  • 1 year, 11 months ago
Glad to hear that.

The info about lw3.ttf is valuable, but it's located in the progtram folder default at "C:\Program Files\Lightworks". Was it missing and where did you get the replacement from?

Project.temp contains now all your existing projects (metadata and backups), but not all supporting files. Don't you need your old projects?
It's better to travel well than to arrive...

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141910

  • JimDaddyO
  • OFFLINE
  • Junior Boarder
  • Posts: 37
  • 1 year, 11 months ago
hugly wrote:
Glad to hear that.

The info about lw3.ttf is valuable, but it's located in the progtram folder default at "C:\Program Files\Lightworks". Was it missing and where did you get the replacement from?

Project.temp contains now all your existing projects (metadata and backups), but not all supporting files. Don't you need your old projects?


No, I don't need the old projects. They are published to You Tube already.

I got the lw3 file somewhere on this forum when searching for answers. Someone had a problem with an earlier version similar to mine and someone else posted up the file. So I copied it as it was missing from my install. I got that error the second time I opened up my new working version of 14.0.

This is the thread....
www.lwks.com/index.php?option=com_kunena&func=view&catid=22&id=105633&Itemid=81

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141918

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 17716
  • 1 year, 11 months ago
Thanks.

If you don't need your old projects, what I would do is to get rid of all unnecessary files before starting new projects, otherwise there will be unused files in Media folder for example.

Delete (or rename or move) the Lightworks folder structure at "C:\Users\Public\Documents\Lightworks\"completely. Re-install V14 to get a clean install (including the complete Lightworks folder structure). User effects and macros have to be re-installed if you have already installed some, though.
It's better to travel well than to arrive...

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141922

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 10672
  • 1 year, 11 months ago
Deleting projects that way will leave any media used by them on your computer. It is an extremely BAD idea.

Copy your old projects except any that already exist in C:\Users\Public\Documents\Lightworks\Projects from C:\Users\Public\Documents\Lightworks\Projects.tmp (if it's not too late!!!). Just copy the unique P and G folders but no other files or folders.

Once you've done that launch Lightworks and delete the projects from the lobby. This will clean up any left over media files.
Last Edit: 1 year, 11 months ago by jwrl.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141923

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 17716
  • 1 year, 11 months ago
Deleting projects that way will leave any media used by them on your computer. It is an extremely BAD idea.

Just to clarify: Deleting the complete folder structure as adviced at
C:\Users\Public\Documents\Lightworks\
deletes everything created by Lightworks Free assuming that you haven't changed or added media locations.

I switch the complete Lightworks folder structure here on a daily basis without reinstalling the program. Access remains connsistent, one of the advantages of the file structure of Lightworks.
It's better to travel well than to arrive...
Last Edit: 1 year, 11 months ago by hugly.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141927

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 10672
  • 1 year, 11 months ago
And you can absolutely guarantee that this thread will only ever be read by free users? Great. Ignore my post #141922 then.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141930

  • JimDaddyO
  • OFFLINE
  • Junior Boarder
  • Posts: 37
  • 1 year, 11 months ago
I am not concerned about the old projects. Little chance I will have to open them again. I think I will just leave it as is, seeing as it is working. Do you think that is OK?
The old projects folder is renamed and the new install put a new projects folder in. Once I make a video it pretty much gets left on it's own. I even delete all the footage that I make the videos from after the video is published.

I noticed that the transition effects I have saved to favourites are still intact, which will make life easier, not that they were anything special, just handy in the favourites. I am still learning things and I mostly do routine tasks with the transitions from one scene to another. I will expand slowly as I experiment.

I have to watch some of the new versions videos to garner more information. I don't do much fancy stuff as they are only You Tube videos I am making on woodworking and shop stuff. It is just a hobby so Lightworks is probably way overpowered for what I am doing, but I like the program and I am just getting accustomed to using it. I don't take very big bites at a time learning things. If it is working correctly and I don't HAVE to do something to it I would rather not. There are still some things I see on other videos, and in the ver. 12 instructional videos, that I would like to experiment with, but so far, I am pleased with the slow progress I am making with it.

Would "staying the course" be OK? or should I start messing with folders further? I notice that double clicking a project in the newly renamed "project temp" folder will not open them in Lightworks anyways, they are marked as OpenDocument Database files under the heading "type" of file.

Thanks again for all the assistance. I know newbies and hobby makers like myself with little knowledge can be kind of a pain to those more experience with questions, but we were all beginners at some point.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141936

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 10672
  • 1 year, 11 months ago
As a free user then yes, what you've done will be fine. That said, even as free user it will always be safer where possible to use Lightworks' own internal systems for handling project management needs. If you were a Pro user there's the potential for there to be rendered media left on your system, and if you transcode or copy on import even as free user there can be media left behind.

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141938

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 17716
  • 1 year, 11 months ago
jwrl wrote:
And you can absolutely guarantee that this thread will only ever be read by free users?

No, I can't. You're absolutely right saying that it is much better to delete projects and other assets from within Lightworks in general.

In this specific case of emergency (Lightworks crashed at startup without meaningful messages and logs) and due to the fact that JimDaddyO said that he won't need his old projects at all, I thought a clean install with a newly created Lightworks folder structure would be the appropriate solution.
It's better to travel well than to arrive...

Re: 14.0 crashes upon opening. 1 year, 11 months ago #141939

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 17716
  • 1 year, 11 months ago
JimDaddyO,

enjoy your future experience with Lightworks.
It's better to travel well than to arrive...

Re: 14.0 crashes upon opening. 1 year, 11 months ago #142088

  • JimDaddyO
  • OFFLINE
  • Junior Boarder
  • Posts: 37
  • 1 year, 11 months ago
Thanks again for the help.

See, this is another reason I really like Lightworks. The community. Ever try to get support from Microsoft?
Time to create page: 0.39 seconds
Scroll To Top