Welcome, Guest
Username Password: Remember me

TOPIC: PNG images don't show up with transparent backgrounds

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110140

  • Steve Esposito
  • OFFLINE
  • Junior Boarder
  • Posts: 28
  • 3 years, 11 months ago
Here is a screen shot of what I get:
Attachments:
  • Attachment This image is hidden for guests. Please log in or register to see it.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110141

  • RWAV
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 6496
  • 3 years, 11 months ago
Could you please post a screen grab of your FX routing panel?

Both methods in the attached work without problem.
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
BETA System
Microsoft Windows 7 Professional 64BIT
HP Z800 Workstation
Last Edit: 3 years, 11 months ago by RWAV.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110143

  • Steve Esposito
  • OFFLINE
  • Junior Boarder
  • Posts: 28
  • 3 years, 11 months ago
I did not use FX routing. That is a screen shot of just pulling it up in the edit window and above it showing where it was added to the project.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110144

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 12020
  • 3 years, 11 months ago
I've just tried it, and I can't find anything wrong with your graphic. It works with a blend, it works with 3D DVE, it works with khaver's alpha feather and my matte key. I even played around with combining it with grading and masking tools.

It just works.

At this stage it would be good to know what your workflow is. It should be

  1. Edit your background on V2 and your PNG image on V1
  2. Add a blend effect to V1. You'll find it in Mixes > Blend.
  3. If the image doesn't appear as you would expect check your blend settings. "Method" at the top of the settings should be "In Front".
  4. If you are seeing the edges outside your image as black change the blend effect to a 3D DVE.
  5. Adjust the crop settings in the DVE to get rid of the black.

If that doesn't work - it should - come back here and we'll see what else can be done.
Last Edit: 3 years, 11 months ago by jwrl.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110148

  • donkpow
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 8989
  • 3 years, 11 months ago
here I have a demonstration that not all png files are created equal. The first is two preview windows in Lightworks. Both have a single .png image with transparent background placed on a single track (V1) in an edit.


This image is hidden for guests. Please log in or register to see it.



Here I have the same files open in the graphics editor just to prove transparency.


This image is hidden for guests. Please log in or register to see it.

HP Z600 5570
PNY Quadro K620
SB Audigy SE
Windows 10 Pro
ShuttlePRO v2

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110151

  • Steve Esposito
  • OFFLINE
  • Junior Boarder
  • Posts: 28
  • 3 years, 11 months ago
Okay, I never had an doubt that it worked on your computers. I showed you what it does on mine. I am running x64 12.5 on Windows 8.1 if that makes any difference.

I did not even add it to a timeline yet, I just showed you how it comes up.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110153

  • donkpow
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 8989
  • 3 years, 11 months ago
Can you put the .png file in a .zip file and share that?
HP Z600 5570
PNY Quadro K620
SB Audigy SE
Windows 10 Pro
ShuttlePRO v2

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110154

  • donkpow
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 8989
  • 3 years, 11 months ago
Do you add and merge a transparent alpha channel layer to your edited photo?
HP Z600 5570
PNY Quadro K620
SB Audigy SE
Windows 10 Pro
ShuttlePRO v2

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110155

  • Steve Esposito
  • OFFLINE
  • Junior Boarder
  • Posts: 28
  • 3 years, 11 months ago
"Can you put the .png file in a .zip file and share that?"

I already posted the file I am trying to use and a screen shot of how it comes up. They are on this thread.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110156

  • Steve Esposito
  • OFFLINE
  • Junior Boarder
  • Posts: 28
  • 3 years, 11 months ago
"Do you add and merge a transparent alpha channel layer to your edited photo?"

In GIMP 2.8 I selected areas and colored them to alpha, or deleted areas revealing an alpha background, then saved the PNG. I don't know if that adds and merges an alpha channel or not.

I re-opened the PNG in other programs and it looks as expected, the same way it looks in GIMP. In Movie Maker the alpha areas are black, but those trees in the already posted screen shot, are not visible even in WMM.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110157

  • Steve Esposito
  • OFFLINE
  • Junior Boarder
  • Posts: 28
  • 3 years, 11 months ago
donkpow wrote:
Can you put the .png file in a .zip file and share that?


Um, scrolling back I am really not sure why you need a zip since you already put the image over a bulldozer and said it worked fine.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110159

  • RWAV
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 6496
  • 3 years, 11 months ago
Because I think donkpow wants to test the idea that posting as an attachment changes the .png file.

You write that you don't use routing. You may not know it but if you have made an effect, yes you do. At this stage it may help if you were to watch the effects tutorials.

I did not even add it to a timeline yet, I just showed you how it comes up
Where???? in a LW viewer??
BETA System
Microsoft Windows 7 Professional 64BIT
HP Z800 Workstation
Last Edit: 3 years, 11 months ago by RWAV.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110162

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 12020
  • 3 years, 11 months ago
RWAV and donkpow, I don't believe that Steve Esposito has attempted to use the graphic at all.

Steve Esposito wrote:
I did not even add it to a timeline yet, I just showed you how it comes up.

Did you read my post and follow the step-by-step, Steve? If you do exactly what's outlined there with the graphic as you uploaded it here it will absolutely definitely work. Looking at a graphic with transparency by itself may not always look as you expect it to.

Don't assume anything, just follow those steps.
Last Edit: 3 years, 11 months ago by jwrl.

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110169

  • donkpow
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 8989
  • 3 years, 11 months ago
Steve Esposito wrote:
"Do you add and merge a transparent alpha channel layer to your edited photo?"

In GIMP 2.8 I selected areas and colored them to alpha, or deleted areas revealing an alpha background, then saved the PNG. I don't know if that adds and merges an alpha channel or not.

I re-opened the PNG in other programs and it looks as expected, the same way it looks in GIMP. In Movie Maker the alpha areas are black, but those trees in the already posted screen shot, are not visible even in WMM.
I think this may be the cause of the issue even though I have not tested it yet. I always open an image as a layer over a transparent background when I need to do like in this latest. I'll go look at that in a minute.

In the gear pictures I put up, the size of one of the files is much bigger than the other.
HP Z600 5570
PNY Quadro K620
SB Audigy SE
Windows 10 Pro
ShuttlePRO v2

Re: PNG images don't show up with transparent backgrounds 3 years, 11 months ago #110172

  • donkpow
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 8989
  • 3 years, 11 months ago
Okay, an effective way to erase, leaving a transparent alpha, in GIMP is to "Add Alpha Channel" before you erase or delete parts of the image. I had to learn how to do it but it definitely works. I haven't tried to fail, yet. I'll do that later today.


This image is hidden for guests. Please log in or register to see it.

HP Z600 5570
PNY Quadro K620
SB Audigy SE
Windows 10 Pro
ShuttlePRO v2
Time to create page: 0.38 seconds
Scroll To Top