Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: Giving up hope (MK 1 Console - 'Device Time Out')

Giving up hope (MK 1 Console - 'Device Time Out') 8 years, 7 months ago #30161

  • BIG_D
Its been about 2 weeks and i can't get this MK1 console to work with Windows 7. I got it to work with Window Vista but no luck with Windows 7. I used the Console drivers and the Console utility but no luck. This might be my last hope to get it to work cause maybe someone on this forum can help me. I've been trying with 3 different types of Serial to USB connectors. I used a USB to Serial, a RS-232 Express card, and a USB to Serial usb stick. Whenever i go to use the utility it tells me "Device Time Out". It finds the console so it says but it times out. Well maybe someone knows why this happening or maybe could point me in the right direction.
Last Edit: 8 years, 7 months ago by Site Admin.

Re: Giving up hope 8 years, 7 months ago #30189

  • Orca
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 415
  • 8 years, 7 months ago
Hi Big_D

Are you on Win7 64-bit? If so we'll need to give you 64 bit drivers with installation instructions. If you need these please send a mail to This e-mail address is being protected from spambots. You need JavaScript enabled to view it and we can supply them.

Re: Giving up hope 8 years, 7 months ago #30835

  • BIG_D
Dear Orca,
Sorry i've taken so long but i just started school but now that i have a few days off i can finally take some time to catch up on emails and such. I haven't worked on or with Lightworks in a while. I haven't been able to use My MK1 console with it at all. What i do is i run the initialization tool and it tells me "Device time out". I'm not gonna lie whenever i see that its like a big middle finger saying HAHA...I've got it to work with Windows Vista but no such luck with windows 7. I tried different serial adapters with it but that didn't work. I even tried restoring my system to factory settings and again no such luck. I have gotten the 64-bit drivers and i've gotten a set of instructions. I have no idea what to do now and if i can't get it to work i dont know what i'll do. I really fell in love with Lightworks when i discovered the console and ever since we've been going steady . Now i'm hoping to get it working but we'll see i dont know if it'll work. I'm still positive.

This image is hidden for guests. Please log in or register to see it.


Thats what happens when i try to use the initialization tool
  • Page:
  • 1
Time to create page: 0.32 seconds
Scroll To Top