Welcome, Guest
Username Password: Remember me

TOPIC: MKII not working anymore

Re: MKII not working anymore 8 months, 2 weeks ago #225923

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 13807
  • 8 months, 2 weeks ago
That may not do it. I use an FTDI converter with my Mk I that uses the same chip as is built in to the USB version of the Mk II. I believe that it requires the same driver. I have no issues, and I'm running 2020.1.1 on W10 Home.
Last Edit: 8 months, 2 weeks ago by jwrl.

Re: MKII not working anymore 8 months, 2 weeks ago #225931

  • RWAV
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 7200
  • 8 months, 2 weeks ago
A little puzzling. Not sure if the referenced post was MAC specific - though that would not be normal for LW.

For a while Console drivers vanished from the website - now they are back.

By now all my systems (HP workstations with onboard serial ports running Win ) have had 2020.1.1 installed. All recognise/run MkI, II and III consoles. So does that mean if a previous FTDI based driver exists the new installation will leave it be?? Or does it auto-remove it?. Haven't had the opportunity yet to investigate.

Guess the current state of play is to wait for Henry51's results - but in any event if that users systems have an onboard serial port then does that not mean that the Peter Gibbs route is irrelevant??
BETA System
Microsoft Windows 7 Professional 64BIT
HP Z800 Workstation

Re: MKII not working anymore 8 months, 2 weeks ago #225943

  • Henry51
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 175
  • 8 months, 2 weeks ago
Unfortunately no results.
It stopped working when I ha a new computer with W10 (before W7).
Even with professional help from Matt yesterday, the console stays dead! Its recognized by Peter Greggs "Lightworks Console Initialization Utility" as a MarkII from 1998, but not working. Power is ok. so may the console is broken?
If you have an idea who could check/repair I would appreciate.
Lightworks 14; 64 Bit; Windows10; Aspire VX15, 16 GB;

Re: MKII not working anymore 8 months, 2 weeks ago #225949

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 30210
  • 8 months, 2 weeks ago
Henry51 wrote:
It stopped working when I ha a new computer with W10 (before W7).
This is another prove of the golden rule "never change a running system". Maybe time to purchase a new Console? Perhaps, the new company has some on stock?
It's better to travel well than to arrive...

Re: MKII not working anymore 8 months, 2 weeks ago #225950

  • briandrys
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 11816
  • 8 months, 2 weeks ago
I gather there are currently no new consoles for sale. Hence the discussion on future consoles in another thread.

Assuming that no one has any suggestions here, you could try a suitable electronics repair company/technician. I got my Steadicam III repaired by a company that fixed ATMs among other things.
Last Edit: 8 months, 2 weeks ago by briandrys.

Re: MKII not working anymore 8 months, 2 weeks ago #225969

  • RWAV
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 7200
  • 8 months, 2 weeks ago
Henry51 wrote:
Unfortunately no results.
It stopped working when I ha a new computer with W10 (before W7)
Has your Pro licence been transferred to the Win 10 box?
BETA System
Microsoft Windows 7 Professional 64BIT
HP Z800 Workstation

Re: MKII not working anymore 8 months, 2 weeks ago #225971

  • Henry51
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 175
  • 8 months, 2 weeks ago
yes! I think its a physical damage on the console...thats the only solution after many different tests. so I need someone who may can repair it.
Lightworks 14; 64 Bit; Windows10; Aspire VX15, 16 GB;

Re: MKII not working anymore 8 months, 2 weeks ago #225972

  • RWAV
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 7200
  • 8 months, 2 weeks ago
The problem is there is no known supply of spare parts for any console let alone a Serial MKII. While there is a broadcast engineer here who has disassembled every console type to replace switches for local users that is only possible while there remains a small supply of spare switches mostly from raiding old LW keyboards.

In the past the official route was to return Consoles to LW for repair - suspect that service is currently not offered.

If your situation is as simple as console working on LW Pro Win7 one day not working on LW Pro Win10 the next it is difficult to reconcile the failure with physical console damage.
BETA System
Microsoft Windows 7 Professional 64BIT
HP Z800 Workstation

Re: MKII not working anymore 8 months, 2 weeks ago #225973

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 13807
  • 8 months, 2 weeks ago
RWAV wrote:
While there is a broadcast engineer here who has disassembled every console type to replace switches for local users that is only possible while there remains a small supply of spare switches mostly from raiding old LW keyboards.

The switches used are Cherry keyboard switches. While the original type used is no longer available, Cherry MX brown are an acceptable replacement. An alternative would be MX clear. The actuation force of the brown is slightly less than the original keys were, and clear is slightly more. They both have the same travel as the originals, and they work and are still being produced.

If you can't get either of those, Cherry MX blue have identical actuation force to the originals, but also have a definite click. I've used Cherry MX blue as a replacement in my mark 1. I replaced both my forward and back keys with them, and used one of the old keys to repair my delete key, which is what had actually failed. I still have the other old key as a spare.
Last Edit: 8 months, 2 weeks ago by jwrl.

Re: MKII not working anymore 8 months, 2 weeks ago #225974

  • RWAV
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 7200
  • 8 months, 2 weeks ago
Hmm - thought currently available Cherry switches were too deep?? Certainly jwrl has done enough of these to be the authority - and we've always kept our spare switch cache so no need to experiment. In any event one faulty switch would not disable the entire console - just that switch function.

This is the connector panel on a Serial Console

This image is hidden for guests. Please log in or register to see it.


jwrl can you recall any need to modify original LW serial console cables when moving onto HP computers. Here we still have some 15m console cables that were in use in the old days - tested one of them still works now. Also have one cable still in a zip-lock bag from probably Patchcom in Sydney labelled "LW Console for HP Computer not tested". Do seem to remember the need to remake cables either going to or migrating from the LW Touch. Absolutely certain we have had some cables which simply did not work on other LW hardware versions.

EDIT - exhumed another bunch of console cables labelled "Touch Console cable new (AMC) crate" and one labelled "original Console Cables".
BETA System
Microsoft Windows 7 Professional 64BIT
HP Z800 Workstation
Last Edit: 8 months, 2 weeks ago by RWAV.

Re: MKII not working anymore 8 months, 2 weeks ago #225975

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 13807
  • 8 months, 2 weeks ago
You can get Cherry keys in two profiles, standard and low profile. The Cherry MX blue are OK in the Mk 1, possibly a low profile version was used in the Mk II/III?

As for the RS-232 cable, from memory you shouldn't need to modify anything. The additional signal lines were for the mouse and keyboard which, if you're like me, you have long ago discarded. You will of course have to provide power, which may have been the reason for the cable mod.

Of course none of this helps Henry51.

Re: MKII not working anymore 8 months, 2 weeks ago #225976

  • Henry51
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 175
  • 8 months, 2 weeks ago
Absolutely right jwrl. Maybe I found an old VIP console somewhere. I know that the MDR Magdeburg, Germany had 7 VIP's I wonder where they are now???
Lightworks 14; 64 Bit; Windows10; Aspire VX15, 16 GB;

Re: MKII not working anymore 8 months, 2 weeks ago #225977

  • RWAV
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 7200
  • 8 months, 2 weeks ago
No, it doesn't specifically help, just that currently other than the console doesn't and seemingly never has worked on the new W10 setup. It's not clear that there has been any evidence of Console maltreatment; so what has happened.

Just looking at past experiences with consoles simply not working to perhaps stumble onto some different clue.

You would of course be familiar with InterLab's "
ISSUE: run_console_series_I&II_via_standard_Sub-D9_port"
document, it includes LW Alacrity which morphed into EditShare's V11 so maybe it's worth checking cable pinouts.

The Console power connector has 8 pins How many of them are significant and if it dates back to last century is it still functioning correctly.
BETA System
Microsoft Windows 7 Professional 64BIT
HP Z800 Workstation

Re: MKII not working anymore 8 months, 2 weeks ago #225979

  • Henry51
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 175
  • 8 months, 2 weeks ago
Not sure if I understand this right RWAV.
I do not think its the power supply - as the console is recognized by Peter
Greggs Console Initiation program under W 10.
On the other hand: under W7 the red STOP button flashes shortly if the program was started. Now all dead....
If the price of the console would not be so crazy high, I think many Lightworker's would buy the Mark III USB.
Don't understand this manufacturers. With this price they sell probably none - a reasonable price and they would sell hundreds!
Lightworks 14; 64 Bit; Windows10; Aspire VX15, 16 GB;

Re: MKII not working anymore 8 months, 2 weeks ago #225981

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 30210
  • 8 months, 2 weeks ago
Henry51 wrote:
Don't understand this manufacturers. With this price they sell probably none - a reasonable price and they would sell hundreds!
I'm not sure if this is true, but I don't know the figures. However, Lightworks sales surely know the figures for the Console and the Shuttle. Obviously, both controllers have been removed from the current portfolio.

The core business of Lightworks has been software development and sales - now, due to the recent change of ownership, more then ever. The console is/was a purchased part, same as the Shuttle. Lightworks was just a parts dealer and service provider. Infrastructure to keep those services alive costs money on a regular basis. If the revenue generated by hardware sales isn't sufficient to maintain the necessary infrastructure over a longer period, the only logical consequence is removing the products from the portfolio. I don't say that this is the reason, but it's the most plausible.

The Lightworks console wouldn't be the only proprietary hardware controller which disappeared from the market over the years.
It's better to travel well than to arrive...
Time to create page: 0.42 seconds
Scroll To Top