Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: Mk II console repair

Mk II console repair 1 month, 3 weeks ago #212917

  • Bertbear
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 62
  • 1 month, 3 weeks ago
Anyone have their Mk II console go completely dead? It was connected to Lightworks, working. I stopped for dinner and returned to a dead console. Not flashing. No lights at all. I've tried on another computer with another cable and nothing.

Has anyone had to repair a non responsive console in this way?

Cheers
Bert

Re: Mk II console repair 1 month, 2 weeks ago #213134

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 23125
  • 1 month, 2 weeks ago
Hello Bertbear,

After three days without response on the forum, have you considered contacting Editshare directly with your request, e.g. by using the form Report a problem?

Maybe they can assist you in finding a strategy how to troubleshoot and fix the problem?

Keep us updated.
It's better to travel well than to arrive...

Re: Mk II console repair 1 month, 2 weeks ago #213136

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 12175
  • 1 month, 2 weeks ago
When I was trying to track down replacement key switches for the very old Cherry white keys used in the Mk I controller they were extremely helpful, even offering to search through old inventory for me. It does sound like it might be a power supply issue though. If it is it will require on-board component replacement. Unless you are able to do the repairs yourself you will definitely need technical help.

I'm not familiar with the electronics of a Mk II, although I have replaced key switches in a couple. However diagnosing power supply issues is not something that I have had to do. And of course, that's always assuming that it is power supply related. It could just as easily be the firmware or the processor. Neither of those could be fixed by anyone other than a certified Lightworks technician.

Re: Mk II console repair 1 month, 2 weeks ago #213185

  • Bertbear
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 62
  • 1 month, 2 weeks ago
Thanks Hugly.

I have left two emails with them already. Still no responses. I’ll try via your suggestion also.

B

Re: Mk II console repair 1 month, 2 weeks ago #213186

  • Bertbear
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 62
  • 1 month, 2 weeks ago
Thanks jwrl. I’m pretty sure it’s going to be an electronic issue as I was using it, left it idle for 30 mins and when I returned the program was still up but the controller wasn’t. Hopefully I’ll get through to EditShare but thanks for your response.

B

Re: Mk II console repair 2 weeks, 1 day ago #214420

  • ArteD
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 498
  • 2 weeks, 1 day ago
Hi,

I'm late to the party and I'm not sure if you solved the problem.

In case not, is it really a MKII or a MKIII (USB)? I ask because you said you tested it with another computer. Since the serial port is no longer something you usually find on several machines, it made me think you have an USB Console (MKIII).

My Consoles are MKII, so serial based. I have had one "die" on me several times. I write "die" because they normally come back online.

With mine it happens if I leave it plugged to the power for days without actually using it or even Lightworks. In other words, if I leave the power supply connected to the outlet while I'm using my station with other programs or not as a Lightworks station.

The Console just turns itself off and won't light up when I start Lightworks. It's almost as if it's an auto shut off.

But then it normally comes back online after a system reboot. Sometimes I have to disconnect the power supply. To be honest, when this happens it can be a bit fiddly to get it back online. But I always manage to do it.

My Consoles are probably 20-25 years old now, so I can't even blame them for acting up. Especially that apart from that they have been extremely reliable. I don't have a single piece of computer hardware even half as old which is still in use.

So in case you haven't solved it, I would bet jwrl's power supply shout is correct on some level. Sounds more like a problem in the power chain than anything else. These things are built like tanks. One of mine has fallen off a car (don't ask. ) and still works, apart from some deep scratches.

Again this is my experience with MKII Consoles. I'm not sure what was changed internally in the USB Consoles.
I'm not employed by or officially represent Editshare or Lightworks. I'm just a Lightworks user.

Re: Mk II console repair 2 weeks ago #214439

  • Bertbear
  • Pro User
  • OFFLINE
  • Senior Boarder
  • Posts: 62
  • 2 weeks ago
Hey ArteD

Thanks for the reply. It's definitely a Mk II console connected via USB and after a lot of generous feedback and advice (plus a few local repair attempts) I decided to send it off to EditShare. It's there now but with everything in shutdown I'm not sure when it'll be fixed.

Brushing up on my keyboard short cuts as a result. I can still work. I'm happy.

Bert
  • Page:
  • 1
Time to create page: 0.34 seconds
Scroll To Top