Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: Some Shuttle pro buttons do not work

Some Shuttle pro buttons do not work 1 year, 8 months ago #188143

  • Henry51
  • Pro User
  • OFFLINE
  • Expert Boarder
  • Posts: 124
  • 1 year, 8 months ago
Finally - after resetting W10 - I got the shuttle pro work. But some buttons do not work as they whould.
How to reprogram them?
Lightworks 12; 64 Bit; Windows7; Lenovo Y 500, 16 GB; Nvidia GT 650 M; Intel Core i7 2,4 Ghz
Serial MK II Console from 1996 with serial to USB adapter

Re: Some Shuttle pro buttons do not work 1 year, 8 months ago #188144

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25311
  • 1 year, 8 months ago
I see you finally decided to stay with the Shuttle for the moment and it's up and running. Good to hear. Since I use it, I call it the Console Mark III.

I suspect you use a keyboard layout different from US/English standards, do you?
It's better to travel well than to arrive...

Re: Some Shuttle pro buttons do not work 1 year, 8 months ago #188145

  • Henry51
  • Pro User
  • OFFLINE
  • Expert Boarder
  • Posts: 124
  • 1 year, 8 months ago
My Laptop has a German keyboard, but I switched to English!
Lightworks 12; 64 Bit; Windows7; Lenovo Y 500, 16 GB; Nvidia GT 650 M; Intel Core i7 2,4 Ghz
Serial MK II Console from 1996 with serial to USB adapter

Re: Some Shuttle pro buttons do not work 1 year, 8 months ago #188146

  • Henry51
  • Pro User
  • OFFLINE
  • Expert Boarder
  • Posts: 124
  • 1 year, 8 months ago
It seems for me that the problem has to do with my key assignments.
I need Zoom In and OUT as well as CUE .
I saved that under MY PREFERENCES (the shuttle pro plugged in!) and than the shit happens when I reload my preferences....
Lightworks 12; 64 Bit; Windows7; Lenovo Y 500, 16 GB; Nvidia GT 650 M; Intel Core i7 2,4 Ghz
Serial MK II Console from 1996 with serial to USB adapter

Re: Some Shuttle pro buttons do not work 1 year, 8 months ago #188147

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25311
  • 1 year, 8 months ago
Henry51 wrote:
My Laptop has a German keyboard, but I switched to English!

Fine, that's what I use, a German keyboard. It took me days to adapt. Here's the beginning of the story: www.lwks.com/index.php?option=com_kunena&func=view&catid=25&id=181671&Itemid=81#181678

The Lightworks presets work only with US/English keyboard layouts properly. To configure in a meaningful way for a German keyboard, you have to change many assignments in the Contour Shuttle configuration software and in Lightworks, carefully, I did it one by one. It's quite complicated to find a complete proper setup which avoids collisions with default shortcuts.

I use a setup far away from defaults, but maybe I can find some presets from an earlier state of development which represent defaults, because that's what I started with. I would share it here, if I can find it. Might take a while.
It's better to travel well than to arrive...
Last Edit: 1 year, 8 months ago by hugly.

Re: Some Shuttle pro buttons do not work 1 year, 8 months ago #188148

  • Henry51
  • Pro User
  • OFFLINE
  • Expert Boarder
  • Posts: 124
  • 1 year, 8 months ago
But my keyboard is set to US Keyboard.....
Lightworks 12; 64 Bit; Windows7; Lenovo Y 500, 16 GB; Nvidia GT 650 M; Intel Core i7 2,4 Ghz
Serial MK II Console from 1996 with serial to USB adapter

Re: Some Shuttle pro buttons do not work 1 year, 8 months ago #188149

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25311
  • 1 year, 8 months ago
Ah, I misunderstood your post. I understand now that switching the keyboard (I meant hardware too) is an option for you. For me it isn't, definitely.

Yes, the Shuttle preference files delivered with Lightworks don't fully represent the Lightworks default shortcuts. Change them to your needs, one by one.
It's better to travel well than to arrive...
Last Edit: 1 year, 8 months ago by hugly.

Re: Some Shuttle pro buttons do not work 1 year, 8 months ago #188150

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25311
  • 1 year, 8 months ago
Allow one side note: Because you are the first one reporting about this problem, as far as I'm aware of, there seem to be only two Shuttle users with a German keyboard on this forum, you and me.

And, that nobody has detected the significant differences in the preset files yet, tells the story that there are only a few Shuttles with Lightworks out there, doesn't it? If true, that's a pitty, because it's a nice device, after proper setup.

Edit: As a bottom line, if you use an english keyboard, my preset files won't help much, because I've optimized for German keyboards.
It's better to travel well than to arrive...
Last Edit: 1 year, 8 months ago by hugly.

Re: Some Shuttle pro buttons do not work 1 year, 4 months ago #194636

  • landshark7
  • Pro User
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • 1 year, 4 months ago
I'm German too - can you please share the presets with me?

Thanks,

Jens

Re: Some Shuttle pro buttons do not work 1 year, 4 months ago #194638

  • briandrys
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 10003
  • 1 year, 4 months ago
Welcome to the forum.

The standard settings are listed here: www.lwks.com/index.php?option=com_kunena&func=view&catid=25&id=184649&Itemid=81

Re: Some Shuttle pro buttons do not work 1 year, 4 months ago #194643

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25311
  • 1 year, 4 months ago
Unfortunately, the default presets for the Contour Shuttle Pro V2 don't work properly with a German keyboard layout, not only some of the buttons are affected, but also the shuttle function. There are changes necessary on the presets of both sides, Lightworks and the Shuttle, to fix.

I will post the modified preset, but it will take some days, because I'm away from my main computer.
It's better to travel well than to arrive...
Last Edit: 1 year, 4 months ago by hugly.

Re: Some Shuttle pro buttons do not work 1 year, 4 months ago #194803

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25311
  • 1 year, 4 months ago
landshark7 wrote:
I'm German too - can you please share the presets with me?

Thanks,

Jens

Does this image from here show you keyboard layout?

This image is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...
Last Edit: 1 year, 4 months ago by hugly.

Re: Some Shuttle pro buttons do not work 1 year, 4 months ago #194804

  • landshark7
  • Pro User
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • 1 year, 4 months ago
Yes... that's the standard German layout ... with the big "Return/Enter" Key and all the umlauts öäü

Re: Some Shuttle pro buttons do not work 1 year, 4 months ago #194808

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25311
  • 1 year, 4 months ago
Thank you.

Have you installed the Shuttle Pro V2 already, including the Contour software 'cdi_shuttle_win_2.13.3-exe'?
It's better to travel well than to arrive...
  • Page:
  • 1
Time to create page: 0.33 seconds
Scroll To Top