Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: Shuttle Pro V2 on German Windows 7 [SOLVED]

Shuttle Pro V2 on German Windows 7 [SOLVED] 2 years ago #181671

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25308
  • 2 years ago
Happily I just unpacked my new Contour Shuttle Pro V2, but unfortunately I detected that "Shuttle Right" wheel sends wrong keystrokes. Some kind of translation seems to take place. This isn't visible with the Contour software, but with Lightworks key assignments and in the timeline due to weird actions. At a first glance I thought the new hardware is the problem and expected random translation, but after a while I detected that it's reproducible and "hardwired" to selected keyboard language of Windows 7. As soon as I set it to English everything is fine, when switching to German the trouble starts.

Has anybody encountered similar problems with a German version of Windows 7 and German keyboard settings together with Shuttle Pro V2 - or vice versa, is there anybody who has no trouble with that setup?

P.S. I run Lightworks with default English Wording, if this is should have any impact to the issue.
It's better to travel well than to arrive...
Last Edit: 2 years ago by hugly.

Re: Shuttle Pro V2 on German Windows 7 2 years ago #181678

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25308
  • 2 years ago
That's turning out to be a funny one.

I gathered that it should be sufficient for proper operations to download most recent Contour software from contourdesign.de/support/ and to load "Contour Shuttle (Windows).prefs" in Lightworks. Is that still the recommendation?

Does anybody know why some key assignments in most recent "Contour Shuttle (Windows).prefs" do not match the associated default keystrokes in application settings "Editshare Lightworks" of most recent Contour Shuttle Device Configuration software (V2.13.3).

Are there modified (corrected) and matching presets available somewhere?
It's better to travel well than to arrive...

Re: Shuttle Pro V2 on German Windows 7 2 years ago #181796

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25308
  • 2 years ago
After going unnecessarily deep into details, assuming and excluding trouble with the Shuttle driver, my installation, third party software, hardware and what not, the problem is caused by the default keymapping of Lightworks.

For the play commands, shortcuts with some shifted special characters are used which are remapped by the keyboard driver with languages different from English predictably (and not only with a German keyboard). I wonder that nobody seems to be aware of that problem on the forum.

Another point: Why does Lightworks expect for e.g. SHIFT+ALT+4 (sent by the shuttle) SHIFT+ALT+$ ? That looks like double translation. "$" is a shifted character already - translation tables focused on English keyboard layout?.

Anyway, what remains from my point of view is that the Jog command doesn't work as precisely as I would have expected it to work. It "overshoots" extremely. The command might be optimized for the huge and heavy jog-wheel of the Mark II console?

An additional jog command optimized for operations with the Contour device would be really nice to have.
It's better to travel well than to arrive...
Last Edit: 2 years ago by hugly.
  • Page:
  • 1
Time to create page: 0.42 seconds
Scroll To Top