Welcome, Guest
Username Password: Remember me

TOPIC: Anybody using an old console (MKI or MKII) with the new beta software?

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 7 months ago #14199

  • doomsday
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 299
  • 9 years, 7 months ago
Greg_E wrote:
It appears to be run on a 5 volt regulator and I see a popular (for the time) TTL to RS232 chip which means converting this to USB is a simple task with a board I already designed for a different project.

Would you be willing to upload or send me the schematic for the board?

I'm interested in seeing how you get the console to work since you obviously have more electronics experience than myself.
Asus X99 Deluxe MB, Intel Core i7 5930K 3.50 GHz cpu, Dual SLI EVGA GTX970s, 32Gb Crucial ddr4 mem, Kingston 450/450 SSD main drive,Second SSD Working drive, Windows 10

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 7 months ago #14214

  • Greg_E
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 2218
  • 9 years, 7 months ago
Let me see what I can do before I get too far into this. A lot of it is really going to depend on the current draw of the entire console, I have a feeling it can be run off of USB power as long as the user does not try to connect the keyboard or mouse. I probably won't get very far until next week, need to find my USB-rs232 adapter which I think I misplaced with a bunch of old Cisco gear.

FYI you can get the schematic for the USB to TTL serial from FTDI which is the chip I used for that other project. They will give you all the components needed to design a USB to TTL serial adapter. They have several styles, the one I was using was to make it as small as possible with normal surface mounted soldering techniques. They do have through hole components so could could maybe build one on perforated board.
Last Edit: 9 years, 7 months ago by Greg_E.

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 7 months ago #14215

  • doomsday
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 299
  • 9 years, 7 months ago
I will wait. In the meantime I have to reproduce one of the buttons that was missing, it will be an easy fix i think.
Asus X99 Deluxe MB, Intel Core i7 5930K 3.50 GHz cpu, Dual SLI EVGA GTX970s, 32Gb Crucial ddr4 mem, Kingston 450/450 SSD main drive,Second SSD Working drive, Windows 10

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 7 months ago #14217

  • Greg_E
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 2218
  • 9 years, 7 months ago
Did you get the same version I did?

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 7 months ago #14218

  • doomsday
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 299
  • 9 years, 7 months ago
yes I did.
Asus X99 Deluxe MB, Intel Core i7 5930K 3.50 GHz cpu, Dual SLI EVGA GTX970s, 32Gb Crucial ddr4 mem, Kingston 450/450 SSD main drive,Second SSD Working drive, Windows 10

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 6 months ago #15341

  • suitepost
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 318
  • 9 years, 6 months ago
We were able to get a series MK1 console to work in the current beta version.
It can be done.

It was not hard.
JWL put a cheap serial RS232 card into the new computer running Win 7 64bit,
Got 64 bit drivers from L/Works.
He had to play around a bit, but it is working fine.
I used it all day on Friday, just like the old days.

Hopefully John will post his experience on the forum soon.
So dust off your old consoles and start editing.
ASUS G53SW Laptop
i7-2630QM, 2.0GHZ
8GB ram
Genforce GTX460M CUDA 1.5GB
Win 7 64bit Lightworks Pro
Lightworks Keyboard + Contour shuttle Pro

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 6 months ago #15361

  • doomsday
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 299
  • 9 years, 6 months ago
I just got my mark I up and running. I think I'm going to enjoy this.
Asus X99 Deluxe MB, Intel Core i7 5930K 3.50 GHz cpu, Dual SLI EVGA GTX970s, 32Gb Crucial ddr4 mem, Kingston 450/450 SSD main drive,Second SSD Working drive, Windows 10

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 5 months ago #16799

  • suitepost
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 318
  • 9 years, 5 months ago
Good News:

I wanted to let you guys know you can get the MK1 console to work
with the new Lightworks beta
Without too much fuss or money.

1- Buy a seperate power supply and have the console converted to run on it
(see other threads in the forum on how to.)

2- Swap your mother board for a mother board with a serial conection built in.
We used the Gigabyte Z motherboard GA-Z 68A-D3-B3
My console now works. [Forget seperate serial cards]

Editing is prue joy now.

What a drag it is to edit with a keyboard and a mouse
I feel so detatched from the material.
So dust off your old consoles and start cutting up a storm.
ASUS G53SW Laptop
i7-2630QM, 2.0GHZ
8GB ram
Genforce GTX460M CUDA 1.5GB
Win 7 64bit Lightworks Pro
Lightworks Keyboard + Contour shuttle Pro

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 5 months ago #16802

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 13616
  • 9 years, 5 months ago
Good to know, Brett. Glad the work wasn't wasted. See you at the shoot out?
Last Edit: 9 years, 5 months ago by jwrl.

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 4 months ago #17782

  • Henry51
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 175
  • 9 years, 4 months ago
Contact me Greg, I have 3 Consoles...
2 x Mark 1
1 x Mark 2
HenryHauck @ sailing-the-world.com
Lightworks 14; 64 Bit; Windows10; Aspire VX15, 16 GB;
Last Edit: 9 years, 4 months ago by Site Admin.

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 4 months ago #17805

  • DJFJEKETE
  • Pro User
  • OFFLINE
  • Expert Boarder
  • Posts: 111
  • 9 years, 4 months ago
I got my Mk1 to work using a serial to usb adapter and this console driver here www.rtcs.co.za/index.php?s=5&p=1

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 4 months ago #17826

  • suitepost
  • Pro User
  • OFFLINE
  • Gold Boarder
  • Posts: 318
  • 9 years, 4 months ago
What brand/type/Model
of serial to USB adapter did you use?

Is it easy to get?
ASUS G53SW Laptop
i7-2630QM, 2.0GHZ
8GB ram
Genforce GTX460M CUDA 1.5GB
Win 7 64bit Lightworks Pro
Lightworks Keyboard + Contour shuttle Pro

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 4 months ago #17827

  • DJFJEKETE
  • Pro User
  • OFFLINE
  • Expert Boarder
  • Posts: 111
  • 9 years, 4 months ago
The type I'am using is this one: tinyurl.com/7b5fsfn

Its very easy to get and works well

Re: Anybody using an old console (MKI or MKII) with the new beta software? 9 years, 4 months ago #17828

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 13616
  • 9 years, 4 months ago
If you want something local, check here.

Re: Anybody using an old console (MKI or MKII) with the new beta software? 8 years, 3 months ago #37302

  • dwarfman
Im trying to setup a evaluation platform to compare LWKS and MC and see where the different benefits are and how you could migrate from one to another.

It´s a 64-bit system and im having problem with LWKS 11.1d and the MKII console, the driver will not install and i see that others have the same problem, but the download driver is 32-bit only ...
How did you get the 64-bit driver? I know it´s out there
Last Edit: 8 years, 3 months ago by .
Time to create page: 0.49 seconds
Scroll To Top