Welcome, Guest
Username Password: Remember me

TOPIC: Audio out of sync

Re: Audio out of sync 3 years, 3 months ago #146073

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 12789
  • 3 years, 3 months ago
As I understand it, there are behavioural differences with the way that 14 deals with frame rates. They are tied up with the ability to handle a wider range of frame rate values. A project started and run entirely in 14 should be OK.

Hopefully this can be addressed in a future release. It's very undesirable to be unable to open an archived project without its behaviour changing.

Re: Audio out of sync 3 years, 3 months ago #146475

  • khelrauko
  • Pro User
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • 3 years, 3 months ago
To be fair, I haven't had the time to check any further. I've created a new project in 14.0 to see if that resolves the issue. I'll report back if I find anything conclusive.

Re: Audio out of sync 3 years, 2 months ago #149490

  • khelrauko
  • Pro User
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • 3 years, 2 months ago
Well, from a good month or so of working with version 14.0, I can confidently say that it does not handle video to audio synchronisation anything like as well as the previous version of Lightworks. I have to consistently process my raw video through a frame rate converter (EyeFrame Converter) to succeed in having synced video. Or to put it another way: I never even had such software installed before v14.0. Same video capture software, same game, same frame rate settings, never once saw any significant desynchronization over a few months of work and several hours of footage.

This isn't a rant, I'm resigned to it until I finish this damn project. Liked Lightworks 12.6, don't like lightworks 14.0. I just thought it worth adding this follow-up.

Re: Audio out of sync 3 years, 2 months ago #149493

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25455
  • 3 years, 2 months ago
Would you mind to make some of your files downloadable at a file hoster of your choice and post the links? The files should show the differences between V12.6 and V14 clearly, maybe a Lightworks archive of a sequence including all media?

I can imagine that there will be Pro users (maybe developers) which have V14 and V12.6 installed interested to find out what's going on.


Unfortunately I can't compare V14 with V12.6 because I have no access to V12.6.
It's better to travel well than to arrive...
Last Edit: 3 years, 2 months ago by hugly.

Re: Audio out of sync 3 years, 2 months ago #149614

  • khelrauko
  • Pro User
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
  • 3 years, 2 months ago
It's a reasonable request, I'll have to look into it next week though, as I'm away for a few days.

Re: Audio out of sync 3 years, 1 month ago #149677

  • hlgame
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • 3 years, 1 month ago
I am a new user and I encountered the same problem. The audio just goes haywire. Looks like a pretty serious defect to me. Until this issue is resolved, I will have to look for an alternative program.

Re: Audio out of sync 3 years, 1 month ago #149680

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25455
  • 3 years, 1 month ago
Hello,

Most sync issues are related to unsuitable footage or underpowered computers, but you'll never find out what's your problem without providing further information about your media and your computer,

On the other hand, maybe it's faster to find another program that meets your needs, I don't know.
It's better to travel well than to arrive...

Re: Audio out of sync 3 years, 1 month ago #149690

  • briandrys
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 10051
  • 3 years, 1 month ago
All professional NLEs won't handle video with variable frame rate. Typically these come from phones, screen capture and other consumer devices, NLEs require a constant frame rate.

If your video doesn't have this, a conversion then becomes part of your workflow before importing.

It's not a defect, since an NLE has to read every frame in order to build up your edit, clip by clip each time you play it, having a variable frame rate would make a huge demand on your computer as it attempts to track it. Highly compressed video files also introduce large computing power requirements.

Re: Audio out of sync 3 years ago #152793

  • reepaz
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • 3 years ago
The thing here that bugs me is I'm having the same issue and the only difference is I've switched from 12.6 to 14.0 and many people are having this issue which they didn't have with 12.6 but no one seems to be willing to say yeah lifeworks 14.0 is the issue.

Re: Audio out of sync 3 years ago #152794

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25455
  • 3 years ago
Hello!

Without knowing exactly what kind of problem your're suffering from, let's assume for a moment that Lightworks V14 is the cause for it and they aren't able to fix that because it depends on third party libraries.

If you would have the choice between a workflow to fix your problem and to search for another software which is able to handle your footage, what would you do?
It's better to travel well than to arrive...

Re: Audio out of sync 3 years ago #152795

  • reepaz
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • 3 years ago
I like Lightworks and the only thing that really annoys me is I can't access the 12.6 version so I'm stuck with a version that doesn't work for me, I'm open to ideas to fix the issue but the problem is I tried EyeFrame and I don't have the time to wait for their conversions while still getting my stuff edited in a timely manner and since this isn't my job also dealing with my real life things and then trying to get in some free time.

Ideally I just don't want to be forced to use something that doesn't work for me when the previous version was working without issue.

Re: Audio out of sync 3 years ago #152796

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25455
  • 3 years ago
Unfortunatly, because of whatever reason, older versions aren't accessible with the free version of Lightworks. That's been part of the license agreement for quite a long time. With the Pro version you would be able to use V12.6.(Personally I wouldn't do that because V14 has fixed some bug I struggled with in the past.)

As you can see solutions for the problem exist obviously. They cost money or time. If you are not willing to invest in either of them, you'll have to wait what next release will bring for you. If your problem should be related to highly compressed MP4 AVC with variable frame rate I believe there won't be much hope to get a fix, but who knows, hope is the last to die.
It's better to travel well than to arrive...

Re: Audio out of sync 3 years ago #153256

  • mfalcon
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
  • 3 years ago
I just started using Lightworks and like it very much, except - every file beyond the first one that is imported has a sync issue.

.MTS 4GB, 1080p, AVCHD, 59.94 fps
Pre-ingest sync = Picture @29.97fps, tried at 30fps as well. (either works on the first file!) Tried various import settings, doesn't make a difference.

raw .MTS files on disk have no sync issue.

LW ver 14.0.0.0(93145), Windows 7/64, i5-4670K @ 3.4ghz, 32GB RAM

Is this a known bug?
Is there an update available or in the works?

Re: Audio out of sync 3 years ago #153262

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 25455
  • 3 years ago
Hello and welcome?

That might be a known issue depending to audio stream delay of MTS files in general and to splitted MTS files of some proprietary formats particularly, or maybe something else. I assume that your problem has nothing to do with the issues discussed here so far, except of that it’s an audio issue.

More information would be needed to try to find possible causes, maybe a fix.

What do you mean saying "raw MTS files on disk have no issues", how do you test that?

What kind of sync issue do you encounter, is audio drifting or is it a constant shift different for each file, or something else?

How has the material been captured (camera, software)?

Please post a mediainfo report of a typical file. Here you'll find directions:
www.lwks.com/index.php?option=com_kunena&func=view&catid=23&id=66072&Itemid=81
It's better to travel well than to arrive...

Re: Audio out of sync 3 years ago #153372

  • mfalcon
  • OFFLINE
  • Fresh Boarder
  • Posts: 4
  • 3 years ago
Thanks for the quick reply.

Test: I can open view all the .MTS files using VLC and there are no sync issues.
Sync issue: the video lags behind the audio ~1 sec, constant, no drift from what I can see.

The video was captured using a DVCAM - by a friend of mine.

So I only see the sync(lag) issue inside of Lightworks.

MediaInfo output:

General
ID                                       : 1 (0x1)
Complete name                            : E:\VIDEO-EDIT\00003.MTS
Format                                   : BDAV
Format/Info                              : Blu-ray Video
File size                                : 3.99 GiB
Duration                                 : 24 min 7 s
Overall bit rate mode                    : Variable
Overall bit rate                         : 23.7 Mb/s
Maximum Overall bit rate                 : 28.0 Mb/s

Video
ID                                       : 4113 (0x1011)
Menu ID                                  : 1 (0x1)
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.2
Format settings, CABAC                   : Yes
Format settings, RefFrames               : 2 frames
Format settings, GOP                     : M=3, N=30
Codec ID                                 : 27
Duration                                 : 24 min 6 s
Bit rate mode                            : Variable
Bit rate                                 : 22.3 Mb/s
Maximum bit rate                         : 25.0 Mb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 59.940 (60000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.180
Stream size                              : 3.76 GiB (94%)

Audio
ID                                       : 4352 (0x1100)
Menu ID                                  : 1 (0x1)
Format                                   : AC-3
Format/Info                              : Audio Coding 3
Format settings, Endianness              : Big
Codec ID                                 : 129
Duration                                 : 24 min 7 s
Bit rate mode                            : Constant
Bit rate                                 : 384 kb/s
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 31.250 FPS (1536 SPF)
Bit depth                                : 16 bits
Compression mode                         : Lossy
Delay relative to video                  : -398 ms
Stream size                              : 66.3 MiB (2%)
Service kind                             : Complete Main

Text
ID                                       : 4608 (0x1200)
Menu ID                                  : 1 (0x1)
Format                                   : PGS
Codec ID                                 : 144
Duration                                 : 24 min 6 s

Time to create page: 0.36 seconds
Scroll To Top