Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: Won't Install

Won't Install 8 months, 1 week ago #185853

  • joepaige.01
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • 8 months, 1 week ago
I'm on a Mac running 10.13.6. I'm trying to download Lightworks but when i click download it won't. I click the thing that says "click here" if it won't download, and I get a message saying "This site can't be reached." I have full internet access. What's wrong?
Last Edit: 8 months, 1 week ago by joepaige.01.

Re: Won't Install 8 months, 1 week ago #185855

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 10985
  • 8 months, 1 week ago
None of the downloads for any operating system appear to be working at the moment. I have reported it, but you may have to wait until office hours UK time for a resolution. At the moment that's roughly six hour's time.

Re: Won't Install 8 months, 1 week ago #185861

  • khaver
  • Pro User
  • NOW ONLINE
  • Platinum Boarder
  • Posts: 3363
  • 8 months, 1 week ago
It's possible they're getting ready for the 14.5 release.
Work Comp: Retired!
Home Comp: Newer! Bigger! Faster!
Send me a tip: paypal.me/4khaver

Re: Won't Install 8 months, 1 week ago #185867

  • briandrys
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 8116
  • 8 months, 1 week ago
I gather the download server is undergoing unexpected maintenance however, the release installers are now using backup locations.

Until it is resolved the beta installers, downloadable documentation and direct emails to @lwks.com are unavailable.
Last Edit: 8 months, 1 week ago by briandrys.

Re: Won't Install 8 months, 1 week ago #185873

  • jwrl
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 10985
  • 8 months, 1 week ago
All downloads and direct emails are now back on line.
Last Edit: 8 months, 1 week ago by jwrl.

Re: Won't Install 8 months, 1 week ago #185887

  • balcony
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
  • 8 months, 1 week ago
The downloads appear to be offline again.

Re: Won't Install 8 months, 1 week ago #185889

  • briandrys
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 8116
  • 8 months, 1 week ago
Welcome to the forum.

Is this V14.00 or the beta and the other downloads?

They seem to be working for me.
Last Edit: 8 months, 1 week ago by briandrys.
  • Page:
  • 1
Time to create page: 0.28 seconds
Scroll To Top