Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: Ubuntu 18.04 - dpkg: dependency problems prevent configuration of lightworks:

Ubuntu 18.04 - dpkg: dependency problems prevent configuration of lightworks: 3 months, 3 weeks ago #175586

  • pla1
  • Pro User
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • 3 months, 3 weeks ago
Hi,

Unable to install Lightworks 14 on a fresh Ubuntu 18.04 installation. Is there a work-around?

htplainf@skull:~/Downloads$ sudo dpkg -i lwks-14.0.0-amd64.deb 
dpkg: warning: downgrading lightworks from 14.5.0.0 to 14.0.0.0
(Reading database ... 177282 files and directories currently installed.)
Preparing to unpack lwks-14.0.0-amd64.deb ...
Unpacking lightworks (14.0.0.0) over (14.5.0.0) ...
dpkg: dependency problems prevent configuration of lightworks:
 lightworks depends on libpango1.0-0 (>= 1.18.0); however:
  Package libpango1.0-0 is not installed.
 lightworks depends on nvidia-cg-toolkit; however:
  Package nvidia-cg-toolkit is not installed.
 lightworks depends on libportaudio2; however:
  Package libportaudio2 is not installed.
 lightworks depends on libportaudiocpp0; however:
  Package libportaudiocpp0 is not installed.
 lightworks depends on libcurl3; however:
  Package libcurl3 is not installed.

dpkg: error processing package lightworks (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1ubuntu3) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for fontconfig (2.12.6-0ubuntu2) ...
Errors were encountered while processing:
 lightworks


Thanks, PLA

Re: Ubuntu 18.04 - dpkg: dependency problems prevent configuration of lightworks: 3 months, 3 weeks ago #175605

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 14638
  • 3 months, 3 weeks ago
Hello and welcome!

It should be possible when using gdebi. I tested that yesterday successfully with Lightworks V14.5 and it works, but please, watch out for errors and warnings when installing most recent versions of other software afterwards.

I hope this will be fixed soon with next releases of V14.5.

For V14.5 RC3 debian package:
$ sudo apt install gdebi-core
$ sudo gdebi Lightworks-145RC3-105359-14.5.0.0.deb


For V14.0 debian package (I didn't test that, but it should work):
$ sudo apt install gdebi-core
$ sudo gdebi lwks-14.0.0-amd64.deb
It's better to travel well than to arrive...

Re: Ubuntu 18.04 - dpkg: dependency problems prevent configuration of lightworks: 3 months, 3 weeks ago #175716

  • pla1
  • Pro User
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • 3 months, 3 weeks ago
gdebi worked. Installed Lightworks-145RC3-105359-14.5.0.0.deb successfully.

Thanks much!

Re: Ubuntu 18.04 - dpkg: dependency problems prevent configuration of lightworks: 3 months, 3 weeks ago #175818

  • drmzperx
  • Pro User
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • 3 months, 3 weeks ago
I would like to use LWKS 14.5 and Virtualbox-5.2 on Ubuntu 18.04 at the same time, but lwks depend on libcurl3 and Virtulabox-5.3 depend on libcurl4. Do you plaing to upgrade lwks to libcurl4? If not, have you any suggestion to running this two programs at the same time?

Thanks,

Re: Ubuntu 18.04 - dpkg: dependency problems prevent configuration of lightworks: 3 months, 3 weeks ago #175819

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 14638
  • 3 months, 3 weeks ago
Hello and welcome!

As it stands now, you can either wait for RC4 or modify the installer package.
It's better to travel well than to arrive...
Last Edit: 3 months, 3 weeks ago by hugly.

Re: Ubuntu 18.04 - dpkg: dependency problems prevent configuration of lightworks: 3 months, 2 weeks ago #175913

  • drmzperx
  • Pro User
  • OFFLINE
  • Fresh Boarder
  • Posts: 2
  • 3 months, 2 weeks ago
I rewrite the dependency libcurl3 to libcurl4 and it works fine!

(Ubuntu 18.04 LTS)

Thanks,

Re: Ubuntu 18.04 - dpkg: dependency problems prevent configuration of lightworks: 3 months, 2 weeks ago #176028

  • geomcd1949
  • Pro User
  • OFFLINE
  • Platinum Boarder
  • Posts: 481
  • 3 months, 2 weeks ago
On Ubuntu 18.04 I find that OBS studio will not work with LW that is installed with Gdebi Package Installer. Nor will some other screen recorders such as Kazam, Simple Screen Recorder, and VokoScreen. If like me, modifying the installer package is over your head, and waiting for RC4 doesn’t satisfy your need for instant gratification, try installing LW RC3 with Software Installer. OBS Studio will record a LW screen.

However, some LW characters will be off, that is, the controls on the Sequence window will be odd, and blocks where check marks would be expected show H’s or sideways H’s. Also, you’ll have to re-install LW after each time it is closed.
North Carolina, USA
Ubuntu 18.04 LTS
2x2.7 GHz E5-2680
500GB SSD and1TB HDD
64 GB DDR3 10600
Quadro K4200
~X-Keys Pro 68 key USB Jog/Shuttle controller
*Galaxy E5 with Filmic Plus*
*JVC GY-HM150*
  • Page:
  • 1
Time to create page: 0.34 seconds
Scroll To Top