Welcome, Guest
Username Password: Remember me
  • Page:
  • 1

TOPIC: Problems with creating a project from an Archive

Problems with creating a project from an Archive 9 years, 1 month ago #6631

  • Odat
  • OFFLINE
  • Senior Boarder
  • Posts: 52
  • 9 years, 1 month ago
I'm working on creating some video tutorials for LW and in the process I noticed some weirdness with creating projects from Archives. Some or all may be bugs, so I thought I'd mention all of them here.


  1. From the project browser, click on the text "[Enter a name]" as if you're going to create a brand new project. The selected text vanishes so you can enter the project name. Now choose "Restore from Archive" and select an archive to load. The "Create" button at the bottom of the window is disabled and can't be clicked. You have to switch back to the "Create a new project" option and type something in the name field to re-enable the create button, and then go back to "Restore from Archive" so you can do the restore. Looks like the dialog has the button disabled because there's no project name, but that shouldn't matter if you decided to load from an archive instead.
  2. Project notes (from the Details tab of the project options) don't get restored when you restore the project, they revert to being empty, as if the project was just created.
  3. When the project is imported, a new empty room is created with the default name "Room #1", as if you created a new project.
  4. The Import dialog box has a progress bar on the bottom that tells you how long the import is going to take. I've noticed that often the progress bar doesn't get all the way filled up. Sometimes it gets about 75% of the way there, and sometimes it displays as only a single pixel or two wide. This seems to happen if your archive has no media in it (or if it did, but you didn't choose picture and audio for the export).
  5. Restoring an archive of a project that has linked media doesn't restore the link (but this has already been reported. Just mentioned here for completeness).


Items number 2 and 3 may be bugs, or just expected behavior, but they caught me by surprise while I was testing, so I thought I'd mention them.

Assuming that the project notes are not expected to be exported along with the archive, I'd like to make that an official feature request. I think it would be useful to use the notes to persist useful information about the project along with it's archive without having to do so manually.

Re: Problems with creating a project from an Archive 9 years, 1 month ago #6912

  • Cookiecutter
  • Administrator
    Pro User
  • OFFLINE
  • Administrator
  • Posts: 2000
  • 9 years, 1 month ago
Thanks Odat! These have all been forwarded to development.
  • Page:
  • 1
Time to create page: 0.25 seconds
Scroll To Top