Welcome, Guest
Username Password: Remember me

TOPIC: Crashes caused by corrupted odb file [issue]

Re: Crashes caused by corrupted odb file [issue] 1 year, 10 months ago #160282

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1547
  • 1 year, 10 months ago
If you have steps to reproduce, that would be great, thanks
Lightworks Development

Re: Crashes caused by corrupted odb file [issue] 1 year, 10 months ago #160288

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 1 year, 10 months ago
This seems to be a similar incident. www.lwks.com/index.php?option=com_kunena&func=view&catid=14&id=159754&Itemid=81#159754

I'll post the steps to force the issue I encountered a bit later.
It's better to travel well than to arrive...
Last Edit: 1 year, 10 months ago by hugly.

Re: Crashes caused by corrupted odb file [issue] 1 year, 10 months ago #160346

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 1 year, 10 months ago
How to reproduce:

In Fixed Layout V1, A1, A2 one clips no cuts no gaps, add Tri-tone effect, then a Blend to the clip and unfold(!) the effects. Add Blur to a marked section. Manually re-route the default routing as shown below and click onto the timeline outside of the Blur to force the crash with V14.0.

This image is hidden for guests. Please log in or register to see it.

This screen recording shows the workflow.

This attachment is hidden for guests. Please log in or register to see it.

I've just detected that the resulting recursive routing doesn't crash the system with V14.1 - Thanks.
It's better to travel well than to arrive...
Last Edit: 1 year, 10 months ago by hugly.

Re: Crashes caused by corrupted odb file [issue] 1 year, 10 months ago #161344

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 1 year, 10 months ago
This is an incident with recursive routing created differently (by deleting FX track).

www.lwks.com/index.php?option=com_kunena&func=view&catid=14&id=141720&limit=15&limitstart=30&Itemid=81#161132

This is a third class of crash, unknown to me so far (V14 and V14.1):
www.lwks.com/index.php?option=com_kunena&func=view&catid=22&id=161284&Itemid=81#161315
It's better to travel well than to arrive...

Re: Crashes caused by corrupted odb file [issue] 1 year, 10 months ago #161467

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 1 year, 10 months ago
Similar to the last one above. The main sequence crashes V14.0 and V14.1. Black vertical lines are visible on empty audio track A2 at cut points of A1. Copies of sections exist showing invalid sequence TC.

www.lwks.com/index.php?option=com_kunena&func=view&catid=14&id=152273&limit=15&limitstart=15&Itemid=81#161462
It's better to travel well than to arrive...
Last Edit: 1 year, 10 months ago by hugly.

Re: Crashes caused by corrupted odb file [issue] 1 year, 9 months ago #162550

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 1 year, 9 months ago
Binary zeros in multiple files, including clips (subclips/prints/syncs?). It's not clear to me if this is already covered by the recent modifications.

www.lwks.com/index.php?option=com_kunena&func=view&catid=14&id=158131&limit=15&limitstart=15&Itemid=81#162503
It's better to travel well than to arrive...

Re: Crashes caused by corrupted odb file [issue] 1 year, 9 months ago #162811

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 1 year, 9 months ago
The fixes of the known issues seem to work fine.

Is the initial problem known which causes files to contain binary zeros?
It's better to travel well than to arrive...
Last Edit: 1 year, 9 months ago by hugly.

Re: Crashes caused by corrupted odb file [issue] 1 year, 7 months ago #169060

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 1 year, 7 months ago
That's new and it's Linux: www.lwks.com/index.php?option=com_kunena&func=view&catid=217&id=169027&Itemid=81#ftop

I can reproduce the issue with the provided project folder on Linux Mint on VM with Lightworks V14.0 and most recent V14.1 RC6. A few seconds after entering the project (in Fixed layout) Lightworks crashes. I've attached my error logs.

The issue is reproducible on Window neither with V14.0 nor with V14.1 RC6.
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...
Last Edit: 1 year, 7 months ago by hugly.

Re: Crashes caused by corrupted odb file [issue] 1 year, 4 months ago #177082

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 1 year, 4 months ago
This seems to be new.

The project posted here has been damaged in a way that it does not show up in project browser.
V14.5 RC4 does not fix the issue, deleting the two damaged files manually does.
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...
Last Edit: 1 year, 4 months ago by hugly.

Re: Crashes caused by corrupted odb file [issue] 1 year ago #184474

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 1 year ago
I don't know how the issue has been created, could be new, could be already fixed.

"Sequence #1" in the project attached below crashes V14.0 and even V14.5 RC12 when replacing clips into timeline. It's been created with V14.0. Some Undo steps stop the crashes, but "sub-frame edit" warnings are shown when replacing/inserting on some positions. With playhead on last outgoing cut, it isn't possible to jump Right to the end of timeline. The project has been posted in this discussion: www.lwks.com/index.php?option=com_kunena&func=view&catid=14&id=184261&Itemid=81#184261
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...

Re: Crashes caused by corrupted odb file [issue] 10 months, 2 weeks ago #187591

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 10 months, 2 weeks ago
Corrupted sequences after crashes on Linux, very similar appearance:

www.lwks.com/index.php?option=com_kunena&func=view&catid=217&id=187569&Itemid=81#187569
www.lwks.com/index.php?option=com_kunena&func=view&catid=6&id=187331&Itemid=81#187331

Both posted projects contain corrupted sequences, content and name are lost, they show invalid TC.

I've attached the project of the most recent incident. It shows two sequences, empty with no name and an object by the name of "Clipboard". Double-click on each to open one by one. One empty sequence opens in recorder, the other in player (it's flagged as sequence but treated like a clip), and "Clipboard" behaves as if it isn't the clipboard but a regular sequence.

Two undo steps on the empty sequence which opens in recorder will crash Lightworks reliably, after restart the sequence is recovered.
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...
Last Edit: 10 months, 2 weeks ago by hugly.

Re: Crashes caused by corrupted odb file [issue] 10 months, 1 week ago #188231

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 10 months, 1 week ago
One of my current test projects shows a similar issue, disappearing tracks in the target sequence, reproducible with Undo and fixable with Redo steps. Different from the above, it doesn't crash on undo. I can't say which editing action caused corruption, if any, or if the issue appeared after a crash. Two undo steps in Edit mode show the corruption. It looks like this:


I'll upload a project backup including media to editshare.wetransfer.com, with reference to this post, now.
It's better to travel well than to arrive...

Re: Crashes caused by corrupted odb file [issue] 5 months, 4 weeks ago #195076

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 5 months, 4 weeks ago
A damaged room crashes Lightworks V14.5 when trying to opened the project in Fixed layout, but not in Flexible. Removing 'UIState.txt' fixes the problem, but the file content doesn't look obviously damaged, from a first glance. The project posted attached.
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...

Re: Crashes caused by corrupted odb file [issue] 5 months, 4 weeks ago #195077

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 20575
  • 5 months, 4 weeks ago
A damaged room crashes Lightworks V14.5 when trying to open the project in Fixed layout, but not in Flexible. Removing 'UIState.txt' fixes the problem, but the file content doesn't look obviously damaged, from a first glance. The project posted here attached.
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...
Last Edit: 5 months, 4 weeks ago by hugly.

Re: Crashes caused by corrupted odb file [issue] 5 months, 3 weeks ago #195092

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1547
  • 5 months, 3 weeks ago
Thanks for the reports. This is already fixed in 14.6, thankfully.

The crash appears to be caused by having the clipboard loaded in the source viewer, but the clipboard has an FX track and no V tracks, which upsets the BITC panel..
Lightworks Development
Time to create page: 0.46 seconds
Scroll To Top