Welcome, Guest
Username Password: Remember me

TOPIC: Second TC Display in Trim View [feature]

Re: Second TC Display in Trim View [feature] 6 days, 4 hours ago #211025

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 6 days, 4 hours ago
Could you imagine the 'Search & replace' panel to be part of the 'Search' panel, as third tab maybe?
It's better to travel well than to arrive...

Re: Second TC Display in Trim View [feature] 6 days, 1 hour ago #211031

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1677
  • 6 days, 1 hour ago
It opens at full screen height which cuts off parts either on top or bottom

Thanks - that's now fixed (in the next build)
Lightworks Development

Re: Second TC Display in Trim View [feature] 5 days, 5 hours ago #211086

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 5 days, 5 hours ago
Trimming audio.

With 'Auto track sync' off and using commands from 'Segment commands.Trim', stereo tracks pairs are ignored, i.e. the single track pointed to is unjoined. That's been confusing to me since the segment commands have been invented, because it allows trimming joined audio channels (e.g. stereo track pairs) out of phase, but it isn't new. Since 2020, the segment sync loss display respects grouped tracks, i.e. it shows track sync loss of the topmost track of the group, wich is fine, basically. However, both together allow bringing joined audio out of phase pretty easily without showing it.



I think this problem wouldn't exist if trimming with segment commands would exactly unjoin what the unjoin assistance, which respects grouped audio tracks, shows, i.e. those commands should do the same as when unjoining with the mouse.
It's better to travel well than to arrive...
Last Edit: 5 days, 5 hours ago by hugly.

Re: Second TC Display in Trim View [feature] 5 days, 1 hour ago #211093

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1677
  • 5 days, 1 hour ago
With 'Auto track sync' off and using commands from 'Segment commands.Trim', stereo tracks pairs are ignored


Thanks - I fixed that one a few days ago as luck would have it
Lightworks Development

Re: Second TC Display in Trim View [feature] 5 days ago #211095

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 5 days ago
Great White wrote:
I fixed that one a few days ago as luck would have it

Glad to hear that, can you stand one more, today?
It's better to travel well than to arrive...

Re: Second TC Display in Trim View [feature] 4 days, 20 hours ago #211109

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1677
  • 4 days, 20 hours ago
hugly wrote:
Great White wrote:
I fixed that one a few days ago as luck would have it

Glad to hear that, can you stand one more, today?

As long as it's easy
Lightworks Development

Re: Second TC Display in Trim View [feature] 4 days, 19 hours ago #211110

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 4 days, 19 hours ago
Ok, this one should be not that hard, at least I hope so.

On a cut with no overlap on both sides, applying a crossfade centered from the context menu The message appears, same as when applying it centered from 'Components.Crosfade', as expected nowadays. When applying the centered crossfade from the 'Crossfades' panel, it appears in the timelines, same as when applying it from 'Components.Crossfade' to a marked section, not expected.


I'm not sure if a crossfade with no overlap does any harm, except of being not effective, but it appears inconsistent.
It's better to travel well than to arrive...
Last Edit: 4 days, 19 hours ago by hugly.

Re: Second TC Display in Trim View [feature] 4 days ago #211147

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 4 days ago
More on trimming grouped audio.

With disabled stero track pairs and 'Auto track sync' enabled, the unjoin assistance looks different for the upper and the lower track and, it doesn't respect disabled grouped tracks, but unjoins single tracks out of a group. With 'Auto track sync' disabled it works as expected. The video start with the latter.

It's better to travel well than to arrive...

Re: Second TC Display in Trim View [feature] 3 days, 22 hours ago #211167

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 3 days, 22 hours ago
Selecting segments on disabled track pairs.

I don't work with selected segment, thus I can't decide whether it's helpful or not to allow segments on disabled tracks to be selected and moved, but I find it feels strange.

With disabled stero track pairs and 'Auto track sync' enabled, single tracks can be selected, it shows a half rectangle. When dragging such a selection, the results differ depending on the position of the mouse on left-button down to drag. I think, segments which split grouped tracks shouldn't exist.

It's better to travel well than to arrive...

Re: Second TC Display in Trim View [feature] 3 days, 19 hours ago #211180

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 3 days, 19 hours ago
No import activity indicated on import.

This isn't new, it isn't even a major issue in my view, but it could appear confusing, at best, to people who are not aware of this behaviour, e.g. person who test the software for the first time, just to see how it 'feels' and if it meets their needs.


The video shows drag&drop, but it applies to the regular import as well. I think, it would be easy to improve just by opening the task log window as soon as import starts and switching to Log mode if drag & drop is executed in Audio or VFX mode.

The video shows also the update of 40 clips, total duration 2 min 34 sec, in h.264 2160p60 format on an AMD 1920x 32GB with source on M.2 SSD. Judge by yourself if this appears competitive enough, imagine a midrange machine, clips of long duration, and source on HDD.
It's better to travel well than to arrive...
Last Edit: 3 days, 18 hours ago by hugly.

Re: Second TC Display in Trim View [feature] 3 days, 1 hour ago #211230

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 3 days, 1 hour ago
Delete removes V1 under certain conditions.

This shows a virtual machine, VMWare 15 on a Window host. V14.5 and 2020 are installed side by side. I can't say for sure, but it's highly unlikely that I've ever touched the default keyboard assignments on this machine. Pressing the Delete-key removes V1, but V1 is not selected.


I cannot reproduce this behaviour on my main Windows installation, but there, I have highly customized and freshly assigned, saved and loaded keyboard settings.
It's better to travel well than to arrive...
Last Edit: 2 days, 23 hours ago by hugly.

Re: Second TC Display in Trim View [feature] 2 days, 20 hours ago #211272

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 2 days, 20 hours ago
Network scan Fedora 30, Windows 10.

It happens that a network scan with valid network connections randomly crashes my new Fedora VM with a segmentation fault and, on Windows it can appear like a hanging system.


Fedora crash logs attached.
Attachments:
  • Attachment This attachment is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...
Last Edit: 2 days, 20 hours ago by hugly.

Re: Second TC Display in Trim View [feature] 2 days, 16 hours ago #211280

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 2 days, 16 hours ago
Switching filters/bins when creating objects.

If 'Filters.Prints' doesn't exist and with focus not on 'Filters.Recent', 'Make.Video Black' switches neither to 'Filters.Recent' nor to 'Filters.Prints' - the newly created object isn't visible without switching manually. If 'Filter.Prints' exists, 'Make.Print' switches to 'Filter.Recent', whereas 'Make.Video Black' switches to 'Filter.Prints' and the object isn't highlighted. Both objects are flagged as prints, why this difference?

Personally, if a bin is selected, I would prefer receiving all newly created derivatives (copies, subclips, whatever) highlighted in that bin, no matter which filter they belong to, if no bin is selected, they should appear in 'Filters.Recent'.
It's better to travel well than to arrive...

Re: Second TC Display in Trim View [feature] 1 day, 21 hours ago #211352

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 1 day, 21 hours ago
Inspired by this feature request.

It's possible to add audio effects in Fixed Flexible layout to 'Favourites' and add them in both layouts to 'Auto effects'. Applying by modifying values works, but it shows strange results.

This image is hidden for guests. Please log in or register to see it.
It's better to travel well than to arrive...
Last Edit: 1 day, 21 hours ago by hugly.

Re: Second TC Display in Trim View [feature] 1 day, 15 hours ago #211368

  • hugly
  • OFFLINE
  • Platinum Boarder
  • Posts: 22161
  • 1 day, 15 hours ago
With viewing LUT enabled with the Pro version the panels for the 'Web' formats 'Youtube' and 'Vimeo' don't show the switch 'Use project viewing LUT'.

This image is hidden for guests. Please log in or register to see it.

Is it enabled or disabled by default and if it's disabled, is there a way to enable it? Based on knowledge of the design of all other export panels, except of Web, the headline "Publish:Youtube" suggests that the video is exported and uploaded with the name "Youtube", but it isn't.
It's better to travel well than to arrive...
Last Edit: 1 day, 15 hours ago by hugly.
Time to create page: 0.35 seconds
Scroll To Top