Welcome, Guest
Username Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Support for polish language (and other) specific characters.

Support for polish language (and other) specific characters. 2 months, 1 week ago #204936

  • hicnar
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 22
  • 2 months, 1 week ago
Hi,

There seems to be some problem with the current version (14.5) of Lightworks not recognizing (or picking up) the system keyboard mapping as set in the OS.
I mean some language specific characters are not being displayed correctly.

For example if the OS system keyboard/language is set to Polish, pressing the right Alt + e combination results in the "ę" character being typed in pretty much every editor app that I use, be it Sublime, MS Word, all kinds of browsers, IntelliJ etc. except in Lightworks where in the Text effect I get the "€" symbol.

The only workaround at that point seems to be copying the text from some other editor else where it is correctly displayed and pasting it the Text box, but in the long run it does not seem like a viable option, at least for me as I do a lot of subtitling work.

That issue has been already described in this www.lwks.com/index.php?option=com_kunena&func=view&catid=27&id=68923&Itemid=81 thread.

Do you lwks folks have any plans to do something about it?

Best!
Krzysztof

PS I have tested and confirmed this behavior in Win10 but will also check on Ubuntu

Re: Support for polish language (and other) specific characters. 2 months, 1 week ago #204937

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1640
  • 2 months, 1 week ago
Do you lwks folks have any plans to do something about it?

That's now fixed (in the next 14.6 beta)
Lightworks Development

Re: Support for polish language (and other) specific characters. 2 months, 1 week ago #204938

  • hicnar
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 22
  • 2 months, 1 week ago
Great news! If it is not a secret, when will the 14.6 beta be becoming a release?

Re: Support for polish language (and other) specific characters. 2 months, 1 week ago #204939

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1640
  • 2 months, 1 week ago
hicnar wrote:
Great news! If it is not a secret, when will the 14.6 beta be becoming a release?

As soon as we're happy with the stability, performance, etc
Lightworks Development

Re: Support for polish language (and other) specific characters. 2 months, 1 week ago #204943

  • hicnar
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 22
  • 2 months, 1 week ago
Well... I've just downloaded and installed the 14.6 beta (Win) and id does not look like the problem has been fixed.

Re: Support for polish language (and other) specific characters. 2 months, 1 week ago #204946

  • RWAV
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 6402
  • 2 months, 1 week ago
Great White wrote:
Do you lwks folks have any plans to do something about it?

That's now fixed (in the next 14.6 beta)
BETA System
Microsoft Windows 7 Professional 64BIT
HP Z800 Workstation

Re: Support for polish language (and other) specific characters. 2 months, 1 week ago #204965

  • hicnar
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 22
  • 2 months, 1 week ago
Nope, it does not appear to be fixed. I am on 14.6 (upgraded from 14.5) beta but still getting exactly the same behavior meaning when I hit right Alt + e I'm getting "€" instead of 'ę'.
Last Edit: 2 months, 1 week ago by hicnar.

Re: Support for polish language (and other) specific characters. 2 months, 1 week ago #204966

  • briandrys
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 8712
  • 2 months, 1 week ago
I suspect they're referring to the next V14.6 beta build, which they're still working on, not the build currently available to download (which is only 2 days old).
Last Edit: 2 months, 1 week ago by briandrys.

Re: Support for polish language (and other) specific characters. 2 months, 1 week ago #204970

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1640
  • 2 months, 1 week ago
briandrys wrote:
I suspect they're referring to the next V14.6 beta build, which they're still working on, not the build currently available to download (which is only 2 days old).

Correct, yes. The next beta.
Lightworks Development

Re: Support for polish language (and other) specific characters. 2 months ago #205376

  • hicnar
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 22
  • 2 months ago
Heh, I assumed that all polish characters would be fixed but it was just the "€" to "ę" that got fixed

Ok, so here is the full list:

A + right alt => Ą
a + right alt => ą
C + right alt => Ć
c + right alt => ć
E + right alt => Ę
e + right alt => ę // that one is fixed
L + right alt => Ł
l + right alt => ł
N + right alt => Ń
n + right alt => ń
O + right alt => Ó
o + right alt => ó
S + right alt => Ś
s + right alt => ś
Z + right alt => Ż
z + right alt => ż
X + right alt => Ź
x + right alt => ź

Where capitals are obviously typed with either left or right shift pressed and held or the caps lock on
Last Edit: 2 months ago by hicnar.

Re: Support for polish language (and other) specific characters. 1 month, 3 weeks ago #205555

  • hicnar
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 22
  • 1 month, 3 weeks ago
Hi there LWKS folks! Could anybody respond to the above please?
Best!
H.

Re: Support for polish language (and other) specific characters. 1 month, 3 weeks ago #205558

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1640
  • 1 month, 3 weeks ago
Thanks for the full list. I'll let you know if/when changes are made
Lightworks Development

Re: Support for polish language (and other) specific characters. 1 month, 3 weeks ago #205576

  • Great White
  • Moderator
    Pro User
  • OFFLINE
  • Moderator
  • Posts: 1640
  • 1 month, 3 weeks ago
Those keypresses should now be handled as expected in the next beta
Lightworks Development

Re: Support for polish language (and other) specific characters. 3 weeks ago #207046

  • hicnar
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 22
  • 3 weeks ago
Just installed the latest Beta and things are looking way better except, in the Polish language "ż" is not same as "ź" (see the original listing above) so...

Right Alt + x should result in ź and not ż
similarly Right Alt + Shift (or with no Shift but with Caps Lock on) + x should result in Ź and not Ż

Other than that it's hunky dory!
H.
Last Edit: 3 weeks ago by hicnar.

Re: Support for polish language (and other) specific characters. 2 weeks, 5 days ago #207191

  • hicnar
  • Pro User
  • OFFLINE
  • Junior Boarder
  • Posts: 22
  • 2 weeks, 5 days ago
Hi,

Anybody from lwks to acknowledge that?

K.
  • Page:
  • 1
  • 2
Time to create page: 0.38 seconds
Scroll To Top